
Pràctiques Blender

1.-En iniciar el Blender veuràs un quadrat al centre de la pantalla (en realitat és un cub) amb el 
contorns de color rosa,  a la seva dreta una mica amunt veuràs un cercle petit i a baix veuràs una 
espècie de políedre complexe. El cub rosa és simplement un objecte que Blender genera per defecte 
per començar a treballar amb ell; que sigui rosa vol dir que està inicialment seleccionat: és així com 
es pot distingir l´objecte seleccionat en cada moment. El cercle petit representa el punt de llum (el 
focus), i el políedre representa la càmara. Coses que hem de saber per començar a treballar amb el 
programa i que cal que provis:

-Per situar el punter 3D (en forma de mirilla de pistola): fem clic amb el botó esquerre 
del ratolí (a partir d´ara, BER) en el lloc de la pantalla desitjat

-Per seleccionar un objecte: fem clic amb el botó dret del ratolí (a partir d´ara, BDR) , 
sobre l'objecte a seleccionar (canviarà a color rosa). Si volem seleccionar més d´un objecte, hem de 
fer el mateix però a més mantenint  pulsada la tecla MAYUS.

-Per a moure un objecte: s´ha de seleccionar i moure'l mantenint pulsat BDR (també es 
pot seleccionar i pulsar "G"). El seu color canviarà a blanc i es mourà junt amb el cursor del ratolí. 
Per a soltar-lo, clicar BER o bé pulsar la tecla ESC.

-Per a rotar un objecte: s´ha de seleccionar i pulsar "R". Per a soltar-lo, clicar BER o 
pulsar la tecla ESC. 

-Per a escalar un objecte: s´ha de seleccionar i pulsar " S". Per a soltar-lo, clicar BER o 
pulsar la ESC. Si es pulsa "N", apareix un quadre amb les dades de posició, rotació i escala de 
l´objecte seleccionat per tal de poder ser editades de cop, bé escrivint la quantitat exacta bé 
augmentant/disminuint la quantitat amb els controls.

-Per a restringir els moviments de posició,rotació i escala només a una dimensió: a més 
de la tecla corresponent ("G","R" o "S") es pulsarà un cop la tecla "X","Y" o "Z" segons la 
dimensió que volguem deixar lliure.

-Per ajustar els moviments de posició,rotació i escala a la graella: a més de la tecla 
corresponent ("G","R" o "S") es mantindrà pulsada a la vegada la tecla CTRL. D´igual manera, es 
pulsarà la tecla ALT si el que es vol és tenir més precisió en el moviment.

-Per retornar a l´estat inicial del Blender: CTRL+X
-Per canviar les diferents vistes de l'escena: (amb el tecla numèric) 

-0 : vista càmara (ortogonal)
-1 : vista de front (ortogonal)
-3 : vista lateral (ortogonal)
-7 : vista de planta -vista des de dalt- (ortogonal, és la vista per defecte)
-5 : canviar la vista actual a mode perspectiva/tornar a mode ortogonal

-Per a canviar el punt de vista: ALT + BER i arrossegar el ratolí.
-Per activar el zoom: CTRL+ALT+BER i arrossegar el ratolí 
-Per poder moure´s per l´escena: MAYUS+ALT+BER i arrossegar el ratolí 
-Per fer que el Blender mostri a la pantalla diferents vistes de la mateixa escena 

simultàniament: És molt típic dels programes 3D mostrar quatre vistes corresponents a les vistes 
0,1,3 i 7 (ortogonal o no). Per fer això, haurem de dividir la pantalla en quatre parts,i això es fa així: 
situem el cursor del ratolí a la frontera entre l´espai que mostra l´escena  i l´espai inferior que conté 
els botons i panels, de tal manera que l´aspecte del cursor canvïi al de dues fletxes negres que 
apunten verticalment en direccions oposades. En aquell moment, s´ha de fer BDR i escollir del 
menú contextual l´opció "Split Area".Apareix una línia de divisió que podem moure fins a situar-la 
a la meitat de la pantalla, i la fixem apretant BER. Tot seguit, tornem a fer el mateix sobre aquesta 
línia de divisió (fem BDR i escollim "Split Area") i torna a aparèixer una línia de divisió aquest cop 
horitzontal; la situem al mig de la pantalla i fem BER. I així fins obtenir quatre vistes. Per eliminar 
la barra de menús de sota de cada vista, s´ha de fer BDR a sobre i seleccionar del menú que apareix 
l´opció "No header". Si és necessari es pot canviar molt ràpidament del mode "4 vistes" al de "Vista 
única" pulsant CTRL+CursorBaix o CTRL+CursorDalt, respectivament.



-Per poder editar individualment a cadascun dels vèrtex d´un objecte en comptes de l
´objecte en si  s´ha de pulsar TAB (fent això entrarem en el mode "edició de vèrtexs" en comptes 
del mode "edició d´objecte"). Un cop fet això, si volem sel.leccionar tots els vèrtexs de l´objecte, 
pulsarem A (els vèrtexs han d´aparèixer ressaltats en groc). Si, pel contrari, volguéssim escollir 
només un vèrtex, estant en aquest mateix mode d´edició de vèrtexs, simplement hem de fer BDR 
sobre el vèrtex desitjat; si volem anar seleccionant més d´un, hem de fer el mateix mantenint 
pulsada a més la tecla MAYUS. Als vèrtexs podrem aplicar les mateixes transformacions que hem 
vist fins ara per figures completes: traslacions, rotacions,etc. Pulsant un altre cop TAB tornaríem a 
tenir l´objecte sencer seleccionat com sempre.

2.-Esborra el cub de la pantalla seleccionant-lo i apretant SUPR. Ara afegirem altres objectes a 
l´escena. Per fer això, apreta la tecla SPACE; haurà de sortir un menú flotant ("la caixa d´eines"). 
Escollirem d´aquí l´opció "Add"->"Mesh" (això vol dir que afegirem una malla poligonal, que és el 
tipus d´objecte més tipus en 3D). En concret, tenim diferents objectes per escollir: un pla, un cub, 
un cercle, una esfera, un cilindre, un paral.lelogram, un con, etc. Seleccionarem l´esfera. Haurà de 
sortir dos quadres consecutius que ens demanaran el número de segments i d´anells amb què volem 
construir l´esfera. Escriviu 40 i 50, per exemple. I ja tenim l´esfera. Fixeu-vos que apareix en mode 
edició de vèrtex: recordeu que apretant TAB torneu al mode d´edició de l´objecte sencer. Proveu 
altres figures.

-Per rotar varis objectes a la vegada: s'ha de seleccionar tots els objectes i repetir els 
pasos anteriors. Abans, però, és convenient establir el punt que serà el centre de rotació. Per 
especificar-lo, haurem d´utilitzar el menú "Rotation/Scale pivot" que hi ha a la barra de menus de 
sota la vista 3D. Hi ha cinc opcions possibles:

-"Active Object": tots els objectes seleccionats giren al voltant de l´últim 
objecte escollit.

-"Individual Centers": en cas que es tingui més d´un objecte seleccionat, 
cadascun girarà entorn al seu propi centre.

-"3D cursor" : la rotació es produeix entorn el cursor.
-"Median Point": la rotació es produeix entorn el centre de gravetat dels 

objecte escollits.
-"Bounding Box Center": Blender calcularà la menor caixa possible que 

conté als objectes seleccionats i els farà girar entorn aquesta caixa (per defecte).

3.-*Duplica l´esfera que has fet en l´exercici anterior. Això es fa de la manera següent: selecciona 
l´objecte a duplicar i pulsa MAYUS+D. Es crearà una còpia exacta, a la mateixa posició; per a 
portar el nou objecte a una posició diferent,només has de desplaçar el ratolí fins fer BER.
*Una altra opció és fer un "duplicat enllaçat", on el segon objecte conservarà sempre les mateixes 
propietats que el primer, fins i tot quan aquestes canvïin. Per fer això, pulsa ALT+D i prova per 
exemple d'alterar la posició d'algun vèrtex d'un de les dues figures per comprovar que l'altre figura 
també es veu afectada.

4.-Una forma de treballar amb malles és utilitzar operacions booleanes (intersecció,unió,diferència) 
Per començar, esborra tots els objectes que tinguis a escena i posa-hi un cub, una esfera i un 
cilindre. Deforma el cub de tal manera que tingui una dimensió molt més curta que les altres dues. 
Ara col.loca l´esfera sobre el cub, de forma que aquest sigui com una base per l´esfera. Finalment, 
selecciona primer el cub i tot seguit l´esfera (l´ordre és important) i pulsa "W". Al menú contextual 
que apareix seleccionarem "Difference" (és per això que l´ordre de selecció és important, perquè 
volem agafar el cub i restar-li l´esfera, i no a l´inrevès). Hauràs d´obtenir ( a part dels objectes 
originals) una espècie de cendrer quadrat.



5.-*¿Com faries per afegir a aquest cendrer les guies a cada cantonada per deixar la cigarreta? Pista: 
resta quatre cops el cilindre al cendrer. 
*¿Quin resultat obtenim si en comptes de la diferència utilitzem la intersecció? Comprova que el 
que s'obté és només l´espai on coincideixen ambdós objectes. 
*¿I quin resultat obtenim d´aplicar la unió?

6.-Torna al començament (CTRL+X) per treballar amb el cub original. Apreta TAB per entrar en el 
mode d´edició de vèrtex i selecciona només els quatre vèrtex que formen una cara. A continuació, 
pulsa "W". Veuràs com s´activa el menú Specials, que ens permet realitzar el següent (prova-ho):

-"Subdivide" : divideix la cara seleccionada
-"Subdivide fractal" : fa el mateix, però desplaça a l´atzar cadascun dels nous vèrtexs 

creats amb un grau d´aleatorietat seleccionat per l´usuari.
-"Merge" : uneix tots els punts seleccionats en un de sol, que es pot situar al centre del 

punts seleccionats o on es trobi el cursor (segons el que s'esculli al quadre emergent).
-"Remove doubles" : elimina els vèrtexs que estiguin a menys de 0.0001 unitats entre sí.
-"Hide"/"Reveal": oculta/torna a mostrar els vèrtexs seleccionats.
-"Select swap" : inverteix la selecció: els vèrtexs seleccionats passen a no ser-ho i 

viceversa.
-"Smooth" : intenta suavitzar la malla
-"Bevel": mètode matemàtic per afegir vèrtexs i suavitzar una malla interactivament.

7.-Amb freqüència ens interessarà que un objecte apunti contínuament a un altre, i no haver 
d´actualitzar la direcció a la què mira cada cop que movem el segon objecte. És el cas de quan 
volem que la càmara apunti a l´objecte principal de l´escena, sense necessitat d´anar-la girant. Per 
aconseguir això, primer seleccionem l´objecte que ha d´apuntar a l´altre, i després seleccionem 
l´objecte al que s´ha de seguir, y pulsem CTRL+T. Per a trencar el seguiment, es pulsa ALT+T. 
Prova-ho amb el cub i la càmara.

8.-*Un altre recurs és l´ús de textes. Pulsa SPACE, i vés a Add->Text. En el panel d´edició 
apareixerà el quadre "Font"  des del qual podrem controlar diversos aspectes del text (alineació, 
tamany,espaiat, inclinació,interlineat i posició).Pots escollir el tipus de lletra apretant el botó "Load"
*Sempre podràs canviar el texte escrit canviant al mode d´edició de vèrtex ("Edit mode") en 
comptes del mode d´edició d´objectes ("Object mode"). Si ho desitgem, per tenir un major control 
sobre el texte, aquest es pot convertir a corbes Bézier pulsant ALT+C, però el pas invers ja no es 
podrà fer (de Bézier a texte). Prova totes aquestes possibilitats.

9.-Esborra tots els objectes presents a l´escena i afegeix un pla. Augmenta el seu tamany. Ara 
genera una malla complexa de vèrtex a partir d´aquest pla fent servir les opcions de subdivisions 
que ofereix el menú "Specials" vist en un exercici anterior. Prova d´alterar la posició, escala o 
rotació d´un grup de punts d´aquesta malla. Veuràs com alteres de manera molt brusca la posició de 
les cares adjacents. Per a suavitzar aquest efecte, pots pulsar la tecla "O", entrant així en el mode 
proporcional. Ara, en desplaçar un punt o grup de punts, aquest desplaçament afectarà lleument als 
vèrtexs colindants. Es pot escollir entre un efecte més suau ("Smooth Falloff") o més brusc ("Sharp 
Falloff") pulsant MAYUS+O. El radi d´influència del suavitzat es pot incrementar o decrementar 
fent servir les tecles + i – del teclat numèric.



10.-*En crear objectes en Blender, l´aspecte per defecte és de "gràfic per ordenador" : una sèrie de 
cares planes i aristes marcades. Això es pot minimitzar activant les capacitats de suavitzat. Per fer 
això, anem al quadre "Link and Materials" del panell inferior del Blender, i fem clic al botó "Set 
Smooth". Per a tornar a l´estil original hauríem de fer "Set Solid".
*Una altra opció és utilitzar el botó "AutoSmooth" del quadre "Mesh" (a la dreta de l´anterior). 
Amb aquesta opció activada Blender suavitza automàticament els angles entre cares contígues si 
aquests són menors que l´especificat amb el botó "Degr".
*Fixa´t que des del quadre "Link and Materials" també podem canviar el color dels objectes amb el 
botó "Material" (entre altres coses). 
*Renderitza l´escena (menú "Render"->"Render current frame") i grava-la en format JPG (menú 
"File-> Save rendered image")...hauràs d'especificar a la caixa de texte superior la carpeta on la 
gravaràs, a la caixa de sota el nom de la image i apretar el botó de guardar.
*Per poder gravar la imatge renderitzada en PNG en comptes de JPG, has de clicar al botó "Panels" 
de l'esquerra del panel inferior de Blender i escollir l'opció "Scene->Render". Veuràs que el 
contingut del panel inferior canvia (de fet, hi ha altres panels, com "Object", que mostra les 
característiques de l'objecte seleccionat, ó "Editing", que és el panel per defecte per editar l'escena, 
ó "Shading", per les qüestions d'il.luminació i textura, etc). Vés a la secció "Format" i allà 
selecciona l'opció PNG del quadre desplegable.

11.-Blender també pot treballar amb corbes Bézier (les mateixes corbes que es fan servir a 
l'Inkscape), entre d'altres tipus. Aquestes corbes permeten una gran flexibilitat en el disseny. Pulsem 
com sempre "SPACE->Add->Curve->Bezier Curve", i ens movem al "mode edició de vèrtexs" amb 
TAB. Als dos extrems de la corba apareixeran dos segments de color rosa, cadascun d´ells amb tres 
nodes de control. Si fem BDR en un node i l´arrosseguem, veurem com la corba és modificada 
corresponentment, fins que apretem BER (o BDR per a cancel.lar). 

-Per moure en bloc tota la corba (traslladar-la de lloc): hem de sel.leccionar tots els 
nodes centrals de cada segment rosa (MAYUS + BDR) i tot seguit BER. La corba seguirà el 
moviment del cursor del nostre ratolí.

-Per afegir un nou punt a la corba: ,a partir de l'extrem seleccionat, CTRL+BER
-Per afegir un node intermig: (si seleccionem dos nodes consecutius), "W"->Subdivide.
-Per eliminar el node seleccionat: "X" (o Supr)->Selected
-Per fer que la unió de dues corbes sigui brusca i no suau: escollim el punt desitjat i "V"
-Per tancar la corba: "C". Podem passar al mode d´edició objectes per veure que hem 

creat una superfície. També pots fer Space->Add ->Curve->Bezier Circle i modificar la posició dels 
nodes de control per fer una figura plana. Utilitza aquest procediment per dibuixar un cor 

-Per afegir volum: Per això farem una extrusió: anirem al quadre "Curve and Surface" 
(F9) del panell inferior del Blender  i modificarem els següents paràmetres:

-"Width" : determina el grosor de l´extrusió
-"Extrude" : determina l´altura que guanyarà l´objecte.
-"Bevel Depth" : determina el tamany del biselat.
-"BevResol" : determina la resolució del biselat.


